<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? - The Investigator</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://theinvestigatornews.com/xmlrpc.php" />
    <meta property="og:image" content="http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg" /><meta name="author" content="Robert Ndawula">
<link rel="icon" type="image/png" href="http://theinvestigatornews.com/wp-content/uploads/2015/10/Investigator-News-Logo-300x300.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-76x76.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-120x120.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-152x152.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-144x144.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-144x144-1.png"/>
<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? - The Investigator" />
<meta property="og:description" content="Share this on WhatsAppPresident Museveni&#8217;s Speech at the Swearing-in Ceremony 2016 H.E. Yoweri Kaguta Museveni PRESIDENT OF THE REPUBLIC OF UGANDA At the SWEARING-IN CEREMONY May12, 2016 &#8211; Kololo Ceremonial Grounds Inaugural Speech Your Excellencies, The visiting Heads of State, Your Excellencies Heads of Delegation, The Honourable Members of visiting delegations, H.E. the Vice President &hellip;" />
<meta property="og:url" content="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" />
<meta property="og:site_name" content="The Investigator" />
<meta property="article:publisher" content="https://web.facebook.com/uginvestigator/" />
<meta property="article:author" content="https://www.facebook.com/grandy.bob" />
<meta property="article:tag" content="museveni" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2016-08-24T12:22:31+00:00" />
<meta property="article:modified_time" content="2016-09-16T16:09:07+00:00" />
<meta property="og:updated_time" content="2016-09-16T16:09:07+00:00" />
<meta property="og:image" content="http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Share this on WhatsAppPresident Museveni&#8217;s Speech at the Swearing-in Ceremony 2016 H.E. Yoweri Kaguta Museveni PRESIDENT OF THE REPUBLIC OF UGANDA At the SWEARING-IN CEREMONY May12, 2016 &#8211; Kololo Ceremonial Grounds Inaugural Speech Your Excellencies, The visiting Heads of State, Your Excellencies Heads of Delegation, The Honourable Members of visiting delegations, H.E. the Vice President [&hellip;]" />
<meta name="twitter:title" content="Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? - The Investigator" />
<meta name="twitter:site" content="@uginvestigator" />
<meta name="twitter:image" content="http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg" />
<meta name="twitter:creator" content="@RosandPost" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Feed" href="http://theinvestigatornews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Comments Feed" href="http://theinvestigatornews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? Comments Feed" href="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theinvestigatornews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://theinvestigatornews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/bwg_frontend.css?ver=1.3.37' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_font-awesome-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/font-awesome/font-awesome.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_mCustomScrollbar-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.css?ver=1.3.37' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_sumoselect-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/sumoselect.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wabtn-style-css'  href='http://theinvestigatornews.com/wp-content/plugins/whatsapp/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://theinvestigatornews.com/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/bwg_frontend.js?ver=1.3.37'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_select_tag":"Select Tag","bwg_search":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.mobile.js?ver=1.3.37'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.3.37'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search."};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/bwg_gallery_box.js?ver=1.3.37'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='http://theinvestigatornews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theinvestigatornews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theinvestigatornews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://theinvestigatornews.com/?p=35890' />
<link rel="alternate" type="application/json+oembed" href="http://theinvestigatornews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theinvestigatornews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F&#038;format=xml" />
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"A7QWi1a8Dy002o", domain:"theinvestigatornews.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=A7QWi1a8Dy002o" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->
<meta name="generator" content="Custom Login v3.2.5" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-1586406238811772",
    enable_page_level_ads: true
  });
</script><meta name="google-site-verification" content="_NCBm8Hr_fxl8xbo50NEl1j9fqXIpQ56D_oKM5GhdP0" /><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/amp/" />
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/theinvestigatornews.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/theinvestigatornews.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#ff0000";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<link rel="icon" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-32x32.png" sizes="32x32" />
<link rel="icon" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-180x180.png" />
<meta name="msapplication-TileImage" content="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="1b2ba8574c0bdeaeef853f5d2c09fef3"><script pagespeed_no_defer="" data-pso-version="20170403_083938">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</script></head>

<body class="post-template-default single single-post postid-35890 single-format-video kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power wpb-js-composer js-comp-ver-4.12 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://web.facebook.com/uginvestigator/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/uginvestigator" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-36814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-36814"><a href="http://theinvestigatornews.com/">Home</a></li>
<li id="menu-item-37072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37072"><a href="http://theinvestigatornews.com/news/business/">Business</a></li>
<li id="menu-item-37070" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-37070"><a href="http://theinvestigatornews.com/news/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://theinvestigatornews.com/news/politics/cartoon/">Cartoon</a></li>
</ul>
</li>
<li id="menu-item-37073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37073"><a href="http://theinvestigatornews.com/news/crime-news/">Crime</a></li>
<li id="menu-item-37071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37071"><a href="http://theinvestigatornews.com/news/opinion/">Opinions</a></li>
<li id="menu-item-38675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38675"><a href="http://theinvestigatornews.com/travel/">Tourism</a></li>
<li id="menu-item-39383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39383"><a target="_blank" href="http://giasafaris.com/properties/">Properties</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://theinvestigatornews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 1
-->

<div class="td-header-wrap td-header-style-1">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-2">
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://web.facebook.com/uginvestigator/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/uginvestigator" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div>
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Saturday, April 22, 2017
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-36778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-36778"><a target="_blank" href="http://theinvestigatornews.com/the-joomla-community/">Advertise with Us</a></li>
<li id="menu-item-36780" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-36780"><a href="http://theinvestigatornews.com/contact/">Contact</a></li>
<li id="menu-item-36781" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36781"><a target="_blank" href="http://theinvestigatornews.com/entrepreneurs/">INVEST-PRENEURS</a></li>
</ul></div></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="http://theinvestigatornews.com/">
            <img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
            <span class="td-visual-hidden">The Investigator</span>
        </a>
                </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  "><a href="http://www.nanjinghotel.co.ug/" target="_blank"><img class="alignnone size-full wp-image-39897" src="http://theinvestigatornews.com/wp-content/uploads/TOP.gif" alt="" width="728" height="90" /></a></div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="http://theinvestigatornews.com/">
			<img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/01/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/01/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://theinvestigatornews.com/">
			<img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-36814"><a href="http://theinvestigatornews.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-37072"><a href="http://theinvestigatornews.com/news/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_58fb808e834f2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_58fb808e834f2" ><script>var block_td_uid_2_58fb808e834f2 = new tdBlock();
block_td_uid_2_58fb808e834f2.id = "td_uid_2_58fb808e834f2";
block_td_uid_2_58fb808e834f2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"1191","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_58fb808e834f2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_58fb808e834f2.td_column_number = "3";
block_td_uid_2_58fb808e834f2.block_type = "td_block_mega_menu";
block_td_uid_2_58fb808e834f2.post_count = "5";
block_td_uid_2_58fb808e834f2.found_posts = "146";
block_td_uid_2_58fb808e834f2.header_color = "";
block_td_uid_2_58fb808e834f2.ajax_pagination_infinite_stop = "";
block_td_uid_2_58fb808e834f2.max_num_pages = "30";
tdBlocksArray.push(block_td_uid_2_58fb808e834f2);
</script><div id=td_uid_2_58fb808e834f2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2016/06/Kasaija.jpg" alt="Finance Minister Hon. Matia Kasaija" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans">2017/18 National Budget Estimates Indicate Tough Times for Ugandans</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/UBC-3-218x150.jpg" alt="UBC Managing Director Winston Agaba Warns David Kazoora" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment ">David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/world-bank-group-launches-new-program-support-africas-top-digital-entrepreneurs/" rel="bookmark" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/WB.gif" alt="XL Africa Scaling Up Digital Innovation" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/world-bank-group-launches-new-program-support-africas-top-digital-entrepreneurs/" rel="bookmark" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs">World Bank Group Launches New Program to Support Africa’s Top Digital&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/uganda-seeks-solve-trade-transportation-outlay-national-logistics-platform/" rel="bookmark" title="Uganda Seeks to Solve Her Trade and Transportation Outlay through the National Logistics Platform"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/TRADE.gif" alt="Uganda mostly transports her Oil and Gas by Trailers because its a Landlocked Country" title="Uganda Seeks to Solve Her Trade and Transportation Outlay through the National Logistics Platform"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/uganda-seeks-solve-trade-transportation-outlay-national-logistics-platform/" rel="bookmark" title="Uganda Seeks to Solve Her Trade and Transportation Outlay through the National Logistics Platform">Uganda Seeks to Solve Her Trade and Transportation Outlay through the&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/mtn-announces-2nd-apps-developers-challenge/" rel="bookmark" title="MTN Announces the 2nd Apps Developers Challenge"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2015/11/MTN-App-Challenge.jpg" alt="MTN Ap Challenge: &#039;Mambo pay&#039; a Start-up led by Charles Muhindo after winning at MTN App Challenge last year" title="MTN Announces the 2nd Apps Developers Challenge"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/mtn-announces-2nd-apps-developers-challenge/" rel="bookmark" title="MTN Announces the 2nd Apps Developers Challenge">MTN Announces the 2nd Apps Developers Challenge</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_58fb808e834f2" data-td_block_id="td_uid_2_58fb808e834f2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_58fb808e834f2" data-td_block_id="td_uid_2_58fb808e834f2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-37070"><a href="http://theinvestigatornews.com/news/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_58fb808e8ee01_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_58fb808e8ee01" ><script>var block_td_uid_3_58fb808e8ee01 = new tdBlock();
block_td_uid_3_58fb808e8ee01.id = "td_uid_3_58fb808e8ee01";
block_td_uid_3_58fb808e8ee01.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"7","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_58fb808e8ee01_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_58fb808e8ee01.td_column_number = "3";
block_td_uid_3_58fb808e8ee01.block_type = "td_block_mega_menu";
block_td_uid_3_58fb808e8ee01.post_count = "4";
block_td_uid_3_58fb808e8ee01.found_posts = "368";
block_td_uid_3_58fb808e8ee01.header_color = "";
block_td_uid_3_58fb808e8ee01.ajax_pagination_infinite_stop = "";
block_td_uid_3_58fb808e8ee01.max_num_pages = "92";
tdBlocksArray.push(block_td_uid_3_58fb808e8ee01);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_3_58fb808e8ee01" id="td_uid_4_58fb808e91d41" data-td_block_id="td_uid_3_58fb808e8ee01" data-td_filter_value="" href="http://theinvestigatornews.com/news/politics/">All</a><a class="mega-menu-sub-cat-td_uid_3_58fb808e8ee01"  id="td_uid_5_58fb808e91e71" data-td_block_id="td_uid_3_58fb808e8ee01" data-td_filter_value="30" href="http://theinvestigatornews.com/news/politics/cartoon/">Cartoon</a></div></div><div id=td_uid_3_58fb808e8ee01 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Politics-218x150.jpg" alt="" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986">Why worry or celebrate? The Rise of Identity and Populist Politics&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/develop-better-ways-operation-stronger-reasons-tax-exemption-mps-uganda-cooperative-alliance/" rel="bookmark" title="Develop Better Ways of Operation, and Stronger Reasons for Tax Exemption –MPs to Uganda Cooperative Alliance"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/MPS.gif" alt="MPs reject SACCOs tax waiver proposal" title="Develop Better Ways of Operation, and Stronger Reasons for Tax Exemption –MPs to Uganda Cooperative Alliance"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/develop-better-ways-operation-stronger-reasons-tax-exemption-mps-uganda-cooperative-alliance/" rel="bookmark" title="Develop Better Ways of Operation, and Stronger Reasons for Tax Exemption –MPs to Uganda Cooperative Alliance">Develop Better Ways of Operation, and Stronger Reasons for Tax Exemption&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/connecting-kamuli-dots-made-political-blessing-curse-musumba/" rel="bookmark" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Musumba-Salaam-218x150.jpg" alt="" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/connecting-kamuli-dots-made-political-blessing-curse-musumba/" rel="bookmark" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba">Connecting the Kamuli dots: What made the Political Blessing into a&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/thieving-government-officials-panic-list-top-corrupt-ministers-tabled-president-museveni/" rel="bookmark" title="Thieving Government Officials: Panic as List of top Corrupt Ministers is tabled before President Museveni"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kaguta-218x150.jpg" alt="" title="Thieving Government Officials: Panic as List of top Corrupt Ministers is tabled before President Museveni"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/thieving-government-officials-panic-list-top-corrupt-ministers-tabled-president-museveni/" rel="bookmark" title="Thieving Government Officials: Panic as List of top Corrupt Ministers is tabled before President Museveni">Thieving Government Officials: Panic as List of top Corrupt Ministers is&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_58fb808e8ee01" data-td_block_id="td_uid_3_58fb808e8ee01"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_58fb808e8ee01" data-td_block_id="td_uid_3_58fb808e8ee01"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-37073"><a href="http://theinvestigatornews.com/news/crime-news/">Crime</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_58fb808e962a5_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_6_58fb808e962a5" ><script>var block_td_uid_6_58fb808e962a5 = new tdBlock();
block_td_uid_6_58fb808e962a5.id = "td_uid_6_58fb808e962a5";
block_td_uid_6_58fb808e962a5.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"73","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_6_58fb808e962a5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_6_58fb808e962a5.td_column_number = "3";
block_td_uid_6_58fb808e962a5.block_type = "td_block_mega_menu";
block_td_uid_6_58fb808e962a5.post_count = "5";
block_td_uid_6_58fb808e962a5.found_posts = "320";
block_td_uid_6_58fb808e962a5.header_color = "";
block_td_uid_6_58fb808e962a5.ajax_pagination_infinite_stop = "";
block_td_uid_6_58fb808e962a5.max_num_pages = "64";
tdBlocksArray.push(block_td_uid_6_58fb808e962a5);
</script><div id=td_uid_6_58fb808e962a5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/UBC-3-218x150.jpg" alt="UBC Managing Director Winston Agaba Warns David Kazoora" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment ">David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Daphne-218x150.jpg" alt="" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion">CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/kicks-dying-horse-gen-kayihura-panics-drags-media-court-mess-kaweesi-murder-probe/" rel="bookmark" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kayihura-3-218x150.jpg" alt="" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/kicks-dying-horse-gen-kayihura-panics-drags-media-court-mess-kaweesi-murder-probe/" rel="bookmark" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe">Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/shock-gen-kayihura-fires-100-detectives-fake-suspects-seeped-scandal-put-hundreds-cases-stake/" rel="bookmark" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/KaleK-218x150.jpg" alt="" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/shock-gen-kayihura-fires-100-detectives-fake-suspects-seeped-scandal-put-hundreds-cases-stake/" rel="bookmark" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal">Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/panamera-murder-assessors-advise-court-acquit-desh-kananura-accomplices-workers-demise-charges/" rel="bookmark" title="Panamera Murder: Assessors Advise Court to Acquit Desh Kananura, Accomplices of Worker’s Demise Charges"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kananura-218x150.jpg" alt="" title="Panamera Murder: Assessors Advise Court to Acquit Desh Kananura, Accomplices of Worker’s Demise Charges"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/panamera-murder-assessors-advise-court-acquit-desh-kananura-accomplices-workers-demise-charges/" rel="bookmark" title="Panamera Murder: Assessors Advise Court to Acquit Desh Kananura, Accomplices of Worker’s Demise Charges">Panamera Murder: Assessors Advise Court to Acquit Desh Kananura, Accomplices of&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_58fb808e962a5" data-td_block_id="td_uid_6_58fb808e962a5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_6_58fb808e962a5" data-td_block_id="td_uid_6_58fb808e962a5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-37071"><a href="http://theinvestigatornews.com/news/opinion/">Opinions</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_7_58fb808e9cf22_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_7_58fb808e9cf22" ><script>var block_td_uid_7_58fb808e9cf22 = new tdBlock();
block_td_uid_7_58fb808e9cf22.id = "td_uid_7_58fb808e9cf22";
block_td_uid_7_58fb808e9cf22.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"32","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_7_58fb808e9cf22_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_7_58fb808e9cf22.td_column_number = "3";
block_td_uid_7_58fb808e9cf22.block_type = "td_block_mega_menu";
block_td_uid_7_58fb808e9cf22.post_count = "5";
block_td_uid_7_58fb808e9cf22.found_posts = "267";
block_td_uid_7_58fb808e9cf22.header_color = "";
block_td_uid_7_58fb808e9cf22.ajax_pagination_infinite_stop = "";
block_td_uid_7_58fb808e9cf22.max_num_pages = "54";
tdBlocksArray.push(block_td_uid_7_58fb808e9cf22);
</script><div id=td_uid_7_58fb808e9cf22 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Politics-218x150.jpg" alt="" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986">Why worry or celebrate? The Rise of Identity and Populist Politics&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/not-overrating-usage-effectiveness-social-networks/" rel="bookmark" title="Are We Not Overrating The Usage and Effectiveness of Social Networks?"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/STELLA.gif" alt="Dr Stella Nyanzi accused of insulting President Yoweri Museveni on Social Media" title="Are We Not Overrating The Usage and Effectiveness of Social Networks?"/></a></div>                <a href="http://theinvestigatornews.com/news/opinion/" class="td-post-category">Opinion</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/not-overrating-usage-effectiveness-social-networks/" rel="bookmark" title="Are We Not Overrating The Usage and Effectiveness of Social Networks?">Are We Not Overrating The Usage and Effectiveness of Social Networks?</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/open-letter-gen-kale-dear-afande-resignation-easter-gift-wonders-ugandans/" rel="bookmark" title="Open Letter to Gen. Kale: Dear Afande, Your Resignation as our Easter Gift would do Wonders to Ugandans"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/KK-218x150.jpg" alt="" title="Open Letter to Gen. Kale: Dear Afande, Your Resignation as our Easter Gift would do Wonders to Ugandans"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/open-letter-gen-kale-dear-afande-resignation-easter-gift-wonders-ugandans/" rel="bookmark" title="Open Letter to Gen. Kale: Dear Afande, Your Resignation as our Easter Gift would do Wonders to Ugandans">Open Letter to Gen. Kale: Dear Afande, Your Resignation as our&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/connecting-kamuli-dots-made-political-blessing-curse-musumba/" rel="bookmark" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Musumba-Salaam-218x150.jpg" alt="" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/connecting-kamuli-dots-made-political-blessing-curse-musumba/" rel="bookmark" title="Connecting the Kamuli dots: What made the Political Blessing into a Curse for Musumba">Connecting the Kamuli dots: What made the Political Blessing into a&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/making-sense-of-stella-nyanzis-arrest/" rel="bookmark" title="Making Sense of Stella Nyanzi&#8217;s Arrest by Government"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/STELLA-1-218x150.jpg" alt="Stella Nyanzi&#039;s methods, although not ideal, proved effective" title="Making Sense of Stella Nyanzi&#8217;s Arrest by Government"/></a></div>                <a href="http://theinvestigatornews.com/news/opinion/" class="td-post-category">Opinion</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/making-sense-of-stella-nyanzis-arrest/" rel="bookmark" title="Making Sense of Stella Nyanzi&#8217;s Arrest by Government">Making Sense of Stella Nyanzi&#8217;s Arrest by Government</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_58fb808e9cf22" data-td_block_id="td_uid_7_58fb808e9cf22"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_58fb808e9cf22" data-td_block_id="td_uid_7_58fb808e9cf22"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-38675"><a href="http://theinvestigatornews.com/travel/">Tourism</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-39383"><a target="_blank" href="http://giasafaris.com/properties/">Properties</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://theinvestigatornews.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div>


<div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://theinvestigatornews.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Politics" class="entry-crumb" itemprop="url" href="http://theinvestigatornews.com/news/politics/"><span itemprop="title">Politics</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days..."><meta itemprop="url" content = "http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/">Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days...</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-35890" class="post-35890 post type-post status-publish format-video has-post-thumbnail hentry category-featured category-politics tag-museveni-2-1040 post_format-post-format-video" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power?</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://theinvestigatornews.com/author/rosand/">Robert Ndawula</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-08-24T12:22:31+00:00" >August 24, 2016</time></span>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-35890">260</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top td-with-like">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F&url=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F&via=uginvestigator"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/&amp;media=http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg&description=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F%20-%20http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" data-text="Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power?" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>

        <div class="td-post-content">

        
                <div class="wpb_video_wrapper">
                    <iframe id="td_youtube_player" width="600" height="560" src="https://www.youtube.com/embed/W6HILYG8_7Q?enablejsapi=1&feature=oembed&wmode=opaque&vq=hd720" frameborder="0" allowfullscreen=""></iframe>
                    <script type="text/javascript">
						var tag = document.createElement("script");
						tag.src = "https://www.youtube.com/iframe_api";

						var firstScriptTag = document.getElementsByTagName("script")[0];
						firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);

						var player;

						function onYouTubeIframeAPIReady() {
							player = new YT.Player("td_youtube_player", {
								height: "720",
								width: "960",
								events: {
									"onReady": onPlayerReady
								}
							});
						}

						function onPlayerReady(event) {
							player.setPlaybackQuality("hd720");
						}
					</script>

                </div>

                
        
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_top ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1586406238811772" data-ad-slot="5182125843"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1586406238811772" data-ad-slot="5182125843"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1586406238811772" data-ad-slot="5182125843"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1586406238811772" data-ad-slot="5182125843"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<!-- WhatsApp Share Button for WordPress: http://peadig.com/wordpress-plugins/whatsapp-share-button/ --><div class="wabtn_container"><a href="whatsapp://send?text=Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? - http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" class="wabtn">Share this on WhatsApp</a></div><p><strong>President Museveni&#8217;s Speech at the Swearing-in Ceremony 2016</strong></p>
<p>H.E. Yoweri Kaguta Museveni</p>
<div class="td-a-rec td-a-rec-id-content_inlineleft  "><a href="https://www.facebook.com/NanjingLugogo/?ref=br_rs" target="_blank"><img class="alignnone size-full wp-image-39895" src="http://theinvestigatornews.com/wp-content/uploads/NANJING-1.gif" alt="" width="300" height="250" /></a></div><p>PRESIDENT OF THE REPUBLIC OF UGANDA</p>
<p>At the</p>
<p>SWEARING-IN CEREMONY</p>
<p>May12, 2016 &#8211; Kololo Ceremonial Grounds</p>
<p>Inaugural Speech</p>
<p>Your Excellencies,</p>
<p>The visiting Heads of State,</p>
<p>Your Excellencies Heads of Delegation,</p>
<p>The Honourable Members of visiting delegations,</p>
<p>H.E. the Vice President of Uganda,</p>
<p>Rt. Hon. Speaker of Parliament,</p>
<p>His Lordship the Chief Justice,</p>
<p>Rt. Hon. Speaker of the East African Legislative Assembly,</p>
<p>The Rt. Hon. Prime Minister,</p>
<p>Their Highnesses the Cultural Leaders,</p>
<p>The Religious Leaders,</p>
<p>All the other Leaders of the State and the NRM Party,</p>
<p>Your Excellencies High Commissioners and Ambassadors,</p>
<p>The NRM fraternity,</p>
<p>Leaders and Members of other Parties,</p>
<p>Distinguished Guests,</p>
<p>All the Wanainchi,</p>
<p>Ladies and Gentlemen,</p>
<p>First of all, I welcome Their Excellencies the visiting Heads of State and Members of the visiting delegations. It is a great honour to us for Your Excellencies and the Honourable Members of the visiting delegations to come and be with us on this happy occasion. Enjoy your stay and, if possible, put aside time to visit the tourist parts of Uganda so that you know more about your country, Uganda, that is exactly mid-way between Alexandria and Cape Town. It is exactly five and-a-half hours from here to Alexandria and five and-a-half hours from here to Cape Town by air.</p>
<p>I congratulate the Ugandans who turned out in big numbers on the 18th of February and on subsequent occasions to vote for the President, Parliament and the different levels of Local Governments. I congratulate the NRM Party for, once again, galvanizing its members and sympathizers to achieve victory at the national and local levels. I also congratulate the other Parties and the Independents who won at the national and local levels. Uganda belongs to everybody.</p>
<p>The NRM has been in power for the last 30 years and has brought Uganda from the abyss of insecurity and despair to now the threshold of becoming a middle-income country by 2020. We would, indeed, have already become a middle-income country if we had more decisively handled the issue of exports. Since GDP is calculated in dollars, the depreciation of the shilling slows down our march to the middle-income status. In the coming five years, we are going to aggressively handle this issue. We shall work hard to export more quantities (and of higher value) of commodities. Where we export unprocessed raw-materials, we get less value and create less jobs.</p>
<p>In the past we could not decisively address this aspect because we had a huge deficit of infrastructure (electricity, tarmac roads, ICT, telephones, piped water, etc). The Ugandans have seen what we have been doing on electricity and the roads. Right now, we, actually, have a surplus of electricity and we are building more dams as you know. Our plan is to build more and more dams, not only on all the sites on the Nile River (Ayago-840MW, Oriang-392MW, Uhuru-400MW, Kiba- 300MW etc.) but also to develop over 40 mini-hydro dams. Mini hydro-dams already under construction include: Nyagak III 5.4MW, Nyamwamba 9MW, Muvumba 5.4MW, Achwa/Agago 83MW, etc.</p>
<p>This is apart from electricity from gas, heavy fuel oil (HFO), solar, etc. In the medium and long-term, we are already preparing for nuclear energy using our vast uranium resources. That is why I forbade the export on any uranium.</p>
<p>On the side of power, we are now remaining with two challenges ─ the high price of electricity per unit on account of the high cost of money used in building the Bujagali dam and the need to build more transmission wires (lines) so that the electricity gets where it is required. The expanding and upgrading of the transmission lines is on-going and will continue. We also have options regarding the bringing down of the cost of Bujagali power. The other dams do not have that problem. The power from Nalubaale power station is now at 1.04US Cents, since the loan for constructing Nalubaale power station has been fully paid back.</p>
<p>That of Bujagali is at 11US cents. The challenge is to bring down the cost of power of Bujagali.</p>
<p>With abundant and cheaper power, our pace of industrialization will pick up. We have already pledged to provide electricity at the cost of 5 American cents per unit to manufacturers, starting with the ones of coffee value addition and textiles. The others will follow. More electricity and better network of roads will mean faster industrialization. As projected by the National Planning Authority (NPA), the middle income status will be attained by 2020.</p>
<p>Moreover, as you know, we are working with our relatives in Kenya to modernize the railway by building the Standard Gauge Railway. This will bring the cost of transport for a 32 metric tonnes container to Mombasa from US dollars 3500 by road, to US dollars 1650 by railway and it will only take one day compared to the present railway which takes 21 days. It will also save our roads from damage caused by the huge lorries carrying what should be ferried by the train.</p>
<p>This is all to do with manufacturing. As I repeatedly tell you, manufacturing is one of the four sectors that comprise our economy. The other three are: agriculture, services and ICT. Peace, electricity and improved road network are stimulating the process of manufacturing. The same stimuli influence services to some extent. Agriculture is, of course, linked to industry through agro-processing.</p>
<p>However, the biggest challenge we have in agriculture is cultural and historical. According to the census of both 2001 and 2014, about 68% of our homesteads are still in subsistence agriculture (only working for food but not working for money). Only 32% of the homesteads are in the money economy. Through Operation Wealth Creation, we are determined to change this. Coffee, fruit and/or tea seedlings will be given to all the homesteads with land of two acres and above. Our ideal model, as you know, is four acres. Two acres, however, can also do something. In some areas, they grow cocoa. Each home must have, at least, one acre of food crops (cassava, bananas, irish potatoes, rice etc).</p>
<p>As far as coffee is concerned, a tissue culture laboratory is going to be built at Kituuza so that we can multiply high quality, disease-free seedlings industrially and quickly. OWC must stop being everywhere and ending up being nowhere.</p>
<p>They must concentrate on, initially, the three cash-crops ─ coffee, fruits and tea. As time goes on, we shall get them to distribute chicken, dairy cattle and pigs. The homesteads with one acre or less, will be helped with poultry for eggs, mushroom growing, onions, pigs and zero-grazing dairy cattle. Every homestead must be involved in money making. We cannot accept spectators in this effort. Maintaining 68% of our homesteads in pre-capitalist modes of production is a wrong form of conservation. Let us conserve other assets such as wetlands, forests, national parks, etc. but not under development.</p>
<p>The services sector is growing very well spurred on by peace and better roads. It is growing at the rate of 5.3% per annum. Especially for tourism, what is now lacking is publicity.</p>
<p>The Tourism Board will aggressively inform the world about our unique climate as well as flora and fauna. Services money is easy money for us, especially tourism.</p>
<p>The ICT sector has been facilitated by the building of the ICT backbone and the undersea cables to Kenya and Tanzania. This has lowered the cost of internet bandwidth from US$1,200 per month to US$ 300 per month and is expected to reduce further to US$150 per month within the next 12 months. Uganda Investment Authority (UIA) should, therefore, use this new capacity to attract new investors in this sector.</p>
<p>With our brothers and sisters in Africa, through EAC and COMESA, we have already built regional markets for our producers. They can export to the region. We have also negotiated for external markets such as AGOA, EBA, the access to the Chinese and the Indian markets, etc.</p>
<p>All these efforts will translate into more jobs for our youth. As I said on the occasion of Labour Day, Uganda already has 3,100 factories and 3,475 tourism related companies and assets.</p>
<p>The two are already employing about 1.1 million people. This has been achieved in spite of the bottlenecks of lack of electricity and high transport costs in the past. Now that we are addressing the issues of electricity and transport costs, our progress will be faster.</p>
<p>Uganda has been at peace for the first time in 500 years, for many years now. Uganda will remain at peace. Nobody has the capacity to disturb this, however hard they might try.</p>
<p>We call upon our African brothers and sisters to work for total peace in Congo, Burundi, Somalia and Central African Republic. I do not have to speak about West Africa and the Sahel because those are abit far. Those nearer know the situation there better than ourselves.</p>
<p>Coming back to the economy, we must expunge two weaknesses ─ corruption by public officials and delay of decision-making. These two mistakes irritate the public and frustrate the investors. It is betraying the country. In this kisanja (term), I will directly deal with the weaknesses.</p>
<p>While in the past I have relied on the accounting officers to do the needful as they are mandated by the constitution, this time I will act directly so as to discipline the Public Service as we disciplined the Army.</p>
<p>I thank you.</p>
<!-- WhatsApp Share Button for WordPress: http://peadig.com/wordpress-plugins/whatsapp-share-button/ --><div class="wabtn_container"><a href="whatsapp://send?text=Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power? - http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" class="wabtn">Share this on WhatsApp</a></div><div class="td-a-rec td-a-rec-id-content_bottom  ">===============================================================
"The Investigator is Uganda’s First Online News Daily with the Latest in Investigative Crime, Politics, Business, Entertainment, Sports, Jobs, Opinions and Analysis.  Contact Us on +256 701 120000, +256 772 097871 or WhatApp on +256 701 760099, Email: info@investigator.co.ug</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F&url=http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F&via=uginvestigator"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/&amp;media=http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg&description=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Kisanja+Hakuna+Muchezo%21+What+do+You+Make+of+President+Museveni%E2%80%99s+100+Days+of+His+5th+Term+in+Power%3F%20-%20http%3A%2F%2Ftheinvestigatornews.com%2F2016%2F08%2Fkisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/" data-text="Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power?" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>                        <div class="author-box-wrap"><a href="http://theinvestigatornews.com/author/rosand/"><img alt='mm' src='http://theinvestigatornews.com/wp-content/uploads/2015/10/ROSAND1-150x150.jpg' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://theinvestigatornews.com/author/rosand/">Robert Ndawula</a></span></div><div class="td-author-url"><a href="http://www.investigator.co.ug">http://www.investigator.co.ug</a></div><div class="td-author-description">Join me for the latest in Business News, Technology, Entrepreneurship in Uganda and Around Africa</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/grandy.bob" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/RosandPost" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/grandy.bob" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/RosandPost" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/RosandPost" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Robert Ndawula"></span><meta itemprop="datePublished" content="2016-08-24T12:22:31+00:00"><meta itemprop="dateModified" content="2016-09-16T16:09:07+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://theinvestigatornews.com/2016/08/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg"></span><meta itemprop="name" content="The Investigator"></span><meta itemprop="headline " content="Kisanja Hakuna Muchezo! What do You Make of President Museveni’s 100 Days of His 5th Term in Power?"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://theinvestigatornews.com/wp-content/uploads/sddefault.jpg"><meta itemprop="width" content="640"><meta itemprop="height" content="480"></span>        </footer>

    </article> <!-- /.post -->

    

<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="post pingback">
        <p>Pingback: <a href='https://ttmuganda.wordpress.com/2017/04/22/pads-hoes-malwa-and-musevenis-hollow-campaign-promises/' rel='external nofollow' class='url'>Pads, hoes, malwa and Museveni’s hollow campaign promises | The Transparent Magazine</a>()</p>
    </li>
    </li><!-- #comment-## -->
            </ul>


        </div>

    </div>

                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td-a-rec td-a-rec-id-sidebar  "><span class="td-adspot-title">Advertisement </span><a href="https://web.facebook.com/bluemountainightclub/" target="_blank"><img class="alignnone size-full wp-image-40046" src="http://theinvestigatornews.com/wp-content/uploads/BLUX.gif" alt="" width="300" height="421" /></a></div><div class="td_block_wrap td_block_7 td_block_widget td_uid_12_58fb808fb2344_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_12_58fb808fb2344" ><script>var block_td_uid_12_58fb808fb2344 = new tdBlock();
block_td_uid_12_58fb808fb2344.id = "td_uid_12_58fb808fb2344";
block_td_uid_12_58fb808fb2344.atts = '{"limit":"4","sort":"random_7_day","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"TRENDING NEWS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"load_more","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_12_58fb808fb2344_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_12_58fb808fb2344.td_column_number = "1";
block_td_uid_12_58fb808fb2344.block_type = "td_block_7";
block_td_uid_12_58fb808fb2344.post_count = "4";
block_td_uid_12_58fb808fb2344.found_posts = "20";
block_td_uid_12_58fb808fb2344.header_color = "#";
block_td_uid_12_58fb808fb2344.ajax_pagination_infinite_stop = "";
block_td_uid_12_58fb808fb2344.max_num_pages = "5";
tdBlocksArray.push(block_td_uid_12_58fb808fb2344);
</script><h4 class="block-title"><span>TRENDING NEWS</span></h4><div id=td_uid_12_58fb808fb2344 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-iv-shock-self-confessed-kaweesi-killer-fails-locate-scene-crime-committed-fatal-sin/" rel="bookmark" title="CIP Records P. IV: Shock as Self-confessed Kaweesi Killer Fails to Locate the Scene of Crime"><img width="100" height="70" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kalekezi-1-100x70.jpg" alt="" title="CIP Records P. IV: Shock as Self-confessed Kaweesi Killer Fails to Locate the Scene of Crime"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-iv-shock-self-confessed-kaweesi-killer-fails-locate-scene-crime-committed-fatal-sin/" rel="bookmark" title="CIP Records P. IV: Shock as Self-confessed Kaweesi Killer Fails to Locate the Scene of Crime">CIP Records P. IV: Shock as Self-confessed Kaweesi Killer Fails to...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-17T22:34:28+00:00" >April 17, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "><img width="100" height="70" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/UBC-3-100x70.jpg" alt="UBC Managing Director Winston Agaba Warns David Kazoora" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment ">David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-22T01:45:23+00:00" >April 22, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"><img width="100" height="70" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Daphne-100x70.jpg" alt="" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion">CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-22T01:11:43+00:00" >April 22, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/make-stay-nanjing-hotel-best-chinese-cuisines-leisure-options/" rel="bookmark" title="Make the Most of your Stay at Nanjing Hotel, Best Chinese Cuisines and Leisure Options"><img width="100" height="53" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/A5.gif" alt="Nanjing Hotel Deluxe business suit" title="Make the Most of your Stay at Nanjing Hotel, Best Chinese Cuisines and Leisure Options"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/make-stay-nanjing-hotel-best-chinese-cuisines-leisure-options/" rel="bookmark" title="Make the Most of your Stay at Nanjing Hotel, Best Chinese Cuisines and Leisure Options">Make the Most of your Stay at Nanjing Hotel, Best Chinese...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-17T14:55:51+00:00" >April 17, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-load-more-wrap"><a href="#" class="td_ajax_load_more td_ajax_load_more_js" id="next-page-td_uid_12_58fb808fb2344" data-td_block_id="td_uid_12_58fb808fb2344">Load more<i class="td-icon-font td-icon-menu-down"></i></a></div></div> <!-- ./block --><div class="td-a-rec td-a-rec-id-custom_ad_1  "><a href="http://www.pakubasafarilodge.com/" target="_blank"><img class="alignnone size-full wp-image-40003" src="http://theinvestigatornews.com/wp-content/uploads/PAKUBI-1.gif" alt="" width="300" height="600" /></a></div><div class="td_block_wrap td_block_15 td_block_widget td_uid_14_58fb809465e72_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_14_58fb809465e72" ><script>var block_td_uid_14_58fb809465e72 = new tdBlock();
block_td_uid_14_58fb809465e72.id = "td_uid_14_58fb809465e72";
block_td_uid_14_58fb809465e72.atts = '{"limit":"6","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"MORE NEWS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_14_58fb809465e72_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_58fb809465e72.td_column_number = "1";
block_td_uid_14_58fb809465e72.block_type = "td_block_15";
block_td_uid_14_58fb809465e72.post_count = "6";
block_td_uid_14_58fb809465e72.found_posts = "9093";
block_td_uid_14_58fb809465e72.header_color = "#";
block_td_uid_14_58fb809465e72.ajax_pagination_infinite_stop = "";
block_td_uid_14_58fb809465e72.max_num_pages = "1516";
tdBlocksArray.push(block_td_uid_14_58fb809465e72);
</script><h4 class="block-title"><span>MORE NEWS</span></h4><div id=td_uid_14_58fb809465e72 class="td_block_inner td-column-1">

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2016/06/Kasaija.jpg" alt="Finance Minister Hon. Matia Kasaija" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans">2017/18 National Budget Estimates Indicate Tough Times for Ugandans</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/UBC-3-218x150.jpg" alt="UBC Managing Director Winston Agaba Warns David Kazoora" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment "/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/david-kazoora-puts-ubc-in-75m-trouble-over-failure-to-pay-for-latest-magic-one-ict-consignment/" rel="bookmark" title="David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay for Latest Magic One ICT Consignment ">David Kazoora Puts UBC  in 75M  Trouble over Failure to Pay...</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/rakai-district-council-insists-denying-general-saleh-owc-extension-land/" rel="bookmark" title="Rakai District Council Insists on Denying General Saleh OWC Extension Land"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Salim-Saleh-218x150.jpg" alt="" title="Rakai District Council Insists on Denying General Saleh OWC Extension Land"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/rakai-district-council-insists-denying-general-saleh-owc-extension-land/" rel="bookmark" title="Rakai District Council Insists on Denying General Saleh OWC Extension Land">Rakai District Council Insists on Denying General Saleh OWC Extension Land</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Daphne-218x150.jpg" alt="" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/cip-records-p-v-nixon-iscariot-gen-kayihura-labors-save-blue-eyed-boys-face-lover-sets-plan-b-motion/" rel="bookmark" title="CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to Save Blue-eyed Boy’s Face as Lover Sets Plan ‘B’ in Motion">CIP Records P. V: Nixon the Iscariot? Gen. Kayihura labors to...</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/kicks-dying-horse-gen-kayihura-panics-drags-media-court-mess-kaweesi-murder-probe/" rel="bookmark" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kayihura-3-218x150.jpg" alt="" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/kicks-dying-horse-gen-kayihura-panics-drags-media-court-mess-kaweesi-murder-probe/" rel="bookmark" title="Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to Court over own Mess in Kaweesi Murder Probe">Kicks of a Dying Horse? Gen Kayihura Panics, Drags Media to...</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_mx4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/world-leaders-recommit-ending-neglected-tropical-diseases-citing-remarkable-progress-since-2012/" rel="bookmark" title="World Leaders Recommit to Ending Neglected Tropical Diseases, Citing Remarkable Progress Since 2012"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/HEALTH.gif" alt="Governments and private donors pledge US$812 million around five-day summit in Geneva" title="World Leaders Recommit to Ending Neglected Tropical Diseases, Citing Remarkable Progress Since 2012"/></a></div>                <a href="http://theinvestigatornews.com/news/africa/" class="td-post-category">Africa</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/world-leaders-recommit-ending-neglected-tropical-diseases-citing-remarkable-progress-since-2012/" rel="bookmark" title="World Leaders Recommit to Ending Neglected Tropical Diseases, Citing Remarkable Progress Since 2012">World Leaders Recommit to Ending Neglected Tropical Diseases, Citing Remarkable Progress...</a></h3>
        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_58fb809465e72" data-td_block_id="td_uid_14_58fb809465e72"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_58fb809465e72" data-td_block_id="td_uid_14_58fb809465e72"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block --><div class="clearfix"></div><div class="td_block_wrap td_block_1 td_block_widget td_uid_15_58fb809472f85_rand td-pb-border-top"  data-td-block-uid="td_uid_15_58fb809472f85" ><script>var block_td_uid_15_58fb809472f85 = new tdBlock();
block_td_uid_15_58fb809472f85.id = "td_uid_15_58fb809472f85";
block_td_uid_15_58fb809472f85.atts = '{"limit":"5","sort":"random_7_day","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Block title","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_15_58fb809472f85_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_15_58fb809472f85.td_column_number = "1";
block_td_uid_15_58fb809472f85.block_type = "td_block_1";
block_td_uid_15_58fb809472f85.post_count = "5";
block_td_uid_15_58fb809472f85.found_posts = "20";
block_td_uid_15_58fb809472f85.header_color = "#";
block_td_uid_15_58fb809472f85.ajax_pagination_infinite_stop = "";
block_td_uid_15_58fb809472f85.max_num_pages = "4";
tdBlocksArray.push(block_td_uid_15_58fb809472f85);
</script><h4 class="block-title"><span>Block title</span></h4><div id=td_uid_15_58fb809472f85 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/mtn-announces-2nd-apps-developers-challenge/" rel="bookmark" title="MTN Announces the 2nd Apps Developers Challenge"><img width="324" height="172" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2015/11/MTN-App-Challenge.jpg" alt="MTN Ap Challenge: &#039;Mambo pay&#039; a Start-up led by Charles Muhindo after winning at MTN App Challenge last year" title="MTN Announces the 2nd Apps Developers Challenge"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/mtn-announces-2nd-apps-developers-challenge/" rel="bookmark" title="MTN Announces the 2nd Apps Developers Challenge">MTN Announces the 2nd Apps Developers Challenge</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/rosand/">Robert Ndawula</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-19T10:21:31+00:00" >April 19, 2017</time></span>                            </div>

            <div class="td-excerpt">
                KAMPALA - MTN Uganda, in partnership with tech and incubation hub; Outbox Hub and Garage48 has launched the 2017 edition of the MTN App...            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/shock-gen-kayihura-fires-100-detectives-fake-suspects-seeped-scandal-put-hundreds-cases-stake/" rel="bookmark" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal"><img width="100" height="70" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/KaleK-100x70.jpg" alt="" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/shock-gen-kayihura-fires-100-detectives-fake-suspects-seeped-scandal-put-hundreds-cases-stake/" rel="bookmark" title="Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped Scandal">Shock as Gen. Kayihura Fires 100 Detectives over Fake Suspects’ Seeped...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-19T16:28:24+00:00" >April 19, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"><img width="100" height="53" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2016/06/Kasaija.jpg" alt="Finance Minister Hon. Matia Kasaija" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/201718-budget-estimates-indicate-tough-times-ugandans/" rel="bookmark" title="2017/18 National Budget Estimates Indicate Tough Times for Ugandans">2017/18 National Budget Estimates Indicate Tough Times for Ugandans</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-22T01:59:09+00:00" >April 22, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/world-bank-group-launches-new-program-support-africas-top-digital-entrepreneurs/" rel="bookmark" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs"><img width="100" height="53" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/WB.gif" alt="XL Africa Scaling Up Digital Innovation" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/world-bank-group-launches-new-program-support-africas-top-digital-entrepreneurs/" rel="bookmark" title="World Bank Group Launches New Program to Support Africa’s Top Digital Entrepreneurs">World Bank Group Launches New Program to Support Africa’s Top Digital...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-20T12:18:06+00:00" >April 20, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"><img width="100" height="70" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Politics-100x70.jpg" alt="" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/04/worry-celebrate-rise-identity-populist-politics-uganda-since-1986/" rel="bookmark" title="Why worry or celebrate? The Rise of Identity and Populist Politics in Uganda Since 1986">Why worry or celebrate? The Rise of Identity and Populist Politics...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-04-18T18:07:36+00:00" >April 18, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->


<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-40107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-40107"><a href="http://theinvestigatornews.com/privacy-policy/">Privacy</a></li>
<li id="menu-item-40108" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40108"><a href="http://theinvestigatornews.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-36784" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36784"><a href="#">Advertisement</a></li>
<li id="menu-item-36785" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36785"><a href="http://theinvestigatornews.com/contact/">Contact Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; The Investigator is Owned and Powered by GIA Investments                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

		<script type="text/javascript">
			jQuery(document).ready(function () {
				jQuery("#post-right-col,#post-sidebar-wrap,.home-mid-col,.home-right-col,#arch-right-col").theiaStickySidebar({"containerSelector":"","additionalMarginTop":65,"additionalMarginBottom":15,"updateSidebarHeight":false,"minWidth":767,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true});
			});
		</script>
		                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2016/02/election-watch-5-days-to-go-museveni-to-attend-juma-prayers-at-old-kampala-besigye-hits-jinja-mbabazi-in-amuria-kyalya-in-budaka/" rel="bookmark" title="ELECTION WATCH—5 DAYS TO GO: Museveni to Attend Juma prayers at Old Kampala, Besigye hits Jinja, Mbabazi in Amuria, Kyalya in Budaka"><img width="301" height="160" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/2016/02/Museveni-1.jpg" alt="" title="ELECTION WATCH—5 DAYS TO GO: Museveni to Attend Juma prayers at Old Kampala, Besigye hits Jinja, Mbabazi in Amuria, Kyalya in Budaka"/></a></div>                <a href="http://theinvestigatornews.com/news/politics/" class="td-post-category">Politics</a>            </div>
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2016/02/election-watch-5-days-to-go-museveni-to-attend-juma-prayers-at-old-kampala-besigye-hits-jinja-mbabazi-in-amuria-kyalya-in-budaka/" rel="bookmark" title="ELECTION WATCH—5 DAYS TO GO: Museveni to Attend Juma prayers at Old Kampala, Besigye hits Jinja, Mbabazi in Amuria, Kyalya in Budaka">ELECTION WATCH—5 DAYS TO GO: Museveni to Attend Juma prayers at...</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/patrick-jaramoji/">Patrick Jaramogi</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-02-12T08:20:40+00:00" >February 12, 2016</time></span>                            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 58fb80948b25a
    -->

    <script>
    jQuery(document).ready(function () {
		jQuery.post('http://theinvestigatornews.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script><script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.5.0'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.4","language":""},"disqusIdentifier":"35890 http:\/\/theinvestigatornews.com\/?p=35890","disqusShortname":"investigatorug","disqusTitle":"Kisanja Hakuna Muchezo! What do You Make of President Museveni\u2019s 100 Days of His 5th Term in Power?","disqusUrl":"http:\/\/theinvestigatornews.com\/2016\/08\/kisanja-hakuna-muchezo-make-president-musevenis-100-days-5th-term-power\/","options":{"manualSync":false},"postId":"35890"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"investigatorug"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.4'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[35890]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://theinvestigatornews.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://theinvestigatornews.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>