<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? - The Investigator</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://theinvestigatornews.com/xmlrpc.php" />
    <meta property="og:image" content="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" /><meta name="author" content="Joel Kenneth Ndawula">
<link rel="icon" type="image/png" href="http://theinvestigatornews.com/wp-content/uploads/2015/10/Investigator-News-Logo-300x300.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-76x76.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-120x120.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-152x152.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-144x144.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://theinvestigatornews.com/wp-content/uploads/apple-icon-144x144-1.png"/>
<!-- This site is optimized with the Yoast SEO plugin v5.0.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? - The Investigator" />
<meta property="og:description" content="Share this on WhatsAppOf recent, institutions have been put under the spotlight on various accounts. Last year, we witnessed the downfall of one of Uganda’s most proclaimed commercial banks. The scandal that saw Dr. Sudhir dropping from the billionaires’ list surfaced and exposed many things that Ugandans should be worried about. Crane bank, as exposed &hellip;" />
<meta property="og:url" content="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" />
<meta property="og:site_name" content="The Investigator" />
<meta property="article:publisher" content="https://web.facebook.com/uginvestigator/" />
<meta property="article:author" content="https://www.facebook.com/insiderpost/?ref=bookmarks" />
<meta property="article:section" content="Business" />
<meta property="article:published_time" content="2017-07-10T14:57:14+00:00" />
<meta property="og:image" content="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="330" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Share this on WhatsAppOf recent, institutions have been put under the spotlight on various accounts. Last year, we witnessed the downfall of one of Uganda’s most proclaimed commercial banks. The scandal that saw Dr. Sudhir dropping from the billionaires’ list surfaced and exposed many things that Ugandans should be worried about. Crane bank, as exposed [&hellip;]" />
<meta name="twitter:title" content="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? - The Investigator" />
<meta name="twitter:site" content="@uginvestigator" />
<meta name="twitter:image" content="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" />
<meta name="twitter:creator" content="@uginvestigator" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Feed" href="http://theinvestigatornews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Comments Feed" href="http://theinvestigatornews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Investigator &raquo; Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? Comments Feed" href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theinvestigatornews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://theinvestigatornews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/bwg_frontend.css?ver=1.3.47' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_font-awesome-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/font-awesome/font-awesome.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_mCustomScrollbar-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.css?ver=1.3.47' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_sumoselect-css'  href='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/css/sumoselect.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wabtn-style-css'  href='http://theinvestigatornews.com/wp-content/plugins/whatsapp/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://theinvestigatornews.com/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/bwg_frontend.js?ver=1.3.47'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_select_tag":"Select Tag","bwg_search":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.mobile.js?ver=1.3.47'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.3.47'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search."};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/photo-gallery/js/bwg_gallery_box.js?ver=1.3.47'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=592e02d19f0427001183ffd2'></script>
<link rel='https://api.w.org/' href='http://theinvestigatornews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theinvestigatornews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theinvestigatornews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<link rel='shortlink' href='http://theinvestigatornews.com/?p=40830' />
<link rel="alternate" type="application/json+oembed" href="http://theinvestigatornews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theinvestigatornews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F&#038;format=xml" />
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"A7QWi1a8Dy002o", domain:"theinvestigatornews.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=A7QWi1a8Dy002o" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->
<meta name="generator" content="Custom Login v3.2.5" />
<meta name="verify-admitad" content="36f6f0537a" /><meta name="google-site-verification" content="_NCBm8Hr_fxl8xbo50NEl1j9fqXIpQ56D_oKM5GhdP0" /><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://theinvestigatornews.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/amp/" />
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/theinvestigatornews.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/theinvestigatornews.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#ff0000";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-88201062-2', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-32x32.png" sizes="32x32" />
<link rel="icon" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-180x180.png" />
<meta name="msapplication-TileImage" content="http://theinvestigatornews.com/wp-content/uploads/2016/07/cropped-ms-icon-310x310-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="1b2ba8574c0bdeaeef853f5d2c09fef3"><script pagespeed_no_defer="" data-pso-version="20170502_060509">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</script></head>

<body class="post-template-default single single-post postid-40830 single-format-standard opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy wpb-js-composer js-comp-ver-4.12 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://web.facebook.com/uginvestigator/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/uginvestigator" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-36814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-36814"><a href="http://theinvestigatornews.com/">Home</a></li>
<li id="menu-item-37072" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37072"><a href="http://theinvestigatornews.com/news/business/">Business</a></li>
<li id="menu-item-37070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-37070"><a href="http://theinvestigatornews.com/news/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://theinvestigatornews.com/news/politics/cartoon/">Cartoon</a></li>
</ul>
</li>
<li id="menu-item-37073" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37073"><a href="http://theinvestigatornews.com/news/crime-news/">Crime</a></li>
<li id="menu-item-37071" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37071"><a href="http://theinvestigatornews.com/news/opinion/">Opinions</a></li>
<li id="menu-item-38675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38675"><a href="http://theinvestigatornews.com/travel/">Tourism</a></li>
<li id="menu-item-39383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39383"><a target="_blank" href="http://giasafaris.com/properties/">Properties</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://theinvestigatornews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 1
-->

<div class="td-header-wrap td-header-style-1">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-2">
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://web.facebook.com/uginvestigator/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/uginvestigator" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div>
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, July 11, 2017
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-36778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-36778"><a target="_blank" href="http://theinvestigatornews.com/the-joomla-community/">Advertise with Us</a></li>
<li id="menu-item-36780" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-36780"><a href="http://theinvestigatornews.com/contact/">Contact</a></li>
<li id="menu-item-36781" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36781"><a target="_blank" href="http://theinvestigatornews.com/entrepreneurs/">INVEST-PRENEURS</a></li>
</ul></div></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="http://theinvestigatornews.com/">
            <img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
            <span class="td-visual-hidden">The Investigator</span>
        </a>
                </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  "><A HREF="https://ad.doubleclick.net/ddm/jump/N3643.2774201THEINVESTIGATOR/B8721338.151753691;sz=728x90;ord=[timestamp]?">

<IMG SRC="https://ad.doubleclick.net/ddm/ad/N3643.2774201THEINVESTIGATOR/B8721338.151753691;sz=728x90;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER=0 WIDTH=728 HEIGHT=90 ALT="Advertisement"></A></div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="http://theinvestigatornews.com/">
			<img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/01/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/01/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://theinvestigatornews.com/">
			<img class="td-retina-data" data-retina="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" src="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg" alt="The Investigator News" title="More Than Just News"/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-36814"><a href="http://theinvestigatornews.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-37072"><a href="http://theinvestigatornews.com/news/business/">Business</a>
<ul  class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_59655a012ea03_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_59655a012ea03" ><script>var block_td_uid_2_59655a012ea03 = new tdBlock();
block_td_uid_2_59655a012ea03.id = "td_uid_2_59655a012ea03";
block_td_uid_2_59655a012ea03.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"1191","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_59655a012ea03_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_59655a012ea03.td_column_number = "3";
block_td_uid_2_59655a012ea03.block_type = "td_block_mega_menu";
block_td_uid_2_59655a012ea03.post_count = "5";
block_td_uid_2_59655a012ea03.found_posts = "207";
block_td_uid_2_59655a012ea03.header_color = "";
block_td_uid_2_59655a012ea03.ajax_pagination_infinite_stop = "";
block_td_uid_2_59655a012ea03.max_num_pages = "42";
tdBlocksArray.push(block_td_uid_2_59655a012ea03);
</script><div id=td_uid_2_59655a012ea03 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Ruparelia-218x150.jpg" alt="" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?">Opinion: Why I Find Government not Solely Guilty of the Pearl&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Nakivuboroad-218x150.jpg" alt="" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!">Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/africas-largest-aviation-academy-graduates-337-aviation-professionals/" rel="bookmark" title="Africa’s Largest Aviation Academy graduates 337 Aviation Professionals"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/ETHIOPIAN.gif" alt="Africa’s Largest Aviation Academy graduates 337 Aviation Professionals" title="Africa’s Largest Aviation Academy graduates 337 Aviation Professionals"/></a></div>                <a href="http://theinvestigatornews.com/news/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/africas-largest-aviation-academy-graduates-337-aviation-professionals/" rel="bookmark" title="Africa’s Largest Aviation Academy graduates 337 Aviation Professionals">Africa’s Largest Aviation Academy graduates 337 Aviation Professionals</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/middle-east-consultants-starts-flying-professionals-lucrative-paying-jobs-abroad-least-600-nurses-doctors-set-shs7m-salary-jobs-libya/" rel="bookmark" title="Middle East Consultants starts flying out Professionals for lucrative paying Jobs abroad with at least 600 Nurses, Doctors set for Shs7m Salary Jobs in Libya"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/MIDDLEEAST.gif" alt="Middle East Consultants starts flying out professionals for lucrative paying jobs abroad" title="Middle East Consultants starts flying out Professionals for lucrative paying Jobs abroad with at least 600 Nurses, Doctors set for Shs7m Salary Jobs in Libya"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/middle-east-consultants-starts-flying-professionals-lucrative-paying-jobs-abroad-least-600-nurses-doctors-set-shs7m-salary-jobs-libya/" rel="bookmark" title="Middle East Consultants starts flying out Professionals for lucrative paying Jobs abroad with at least 600 Nurses, Doctors set for Shs7m Salary Jobs in Libya">Middle East Consultants starts flying out Professionals for lucrative paying Jobs&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/police-issues-stern-warning-ugandans-seeking-work-middle-east-tells-good-ambassadors/" rel="bookmark" title="Police Issues Stern Warning to Ugandans Seeking to Work in Middle East, Tells them to be Good Ambassadors"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Midel-East-218x150.jpg" alt="" title="Police Issues Stern Warning to Ugandans Seeking to Work in Middle East, Tells them to be Good Ambassadors"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/police-issues-stern-warning-ugandans-seeking-work-middle-east-tells-good-ambassadors/" rel="bookmark" title="Police Issues Stern Warning to Ugandans Seeking to Work in Middle East, Tells them to be Good Ambassadors">Police Issues Stern Warning to Ugandans Seeking to Work in Middle&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_59655a012ea03" data-td_block_id="td_uid_2_59655a012ea03"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_59655a012ea03" data-td_block_id="td_uid_2_59655a012ea03"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-37070"><a href="http://theinvestigatornews.com/news/politics/">Politics</a>
<ul  class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_59655a0133d34_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_59655a0133d34" ><script>var block_td_uid_3_59655a0133d34 = new tdBlock();
block_td_uid_3_59655a0133d34.id = "td_uid_3_59655a0133d34";
block_td_uid_3_59655a0133d34.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"7","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_59655a0133d34_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_59655a0133d34.td_column_number = "3";
block_td_uid_3_59655a0133d34.block_type = "td_block_mega_menu";
block_td_uid_3_59655a0133d34.post_count = "4";
block_td_uid_3_59655a0133d34.found_posts = "382";
block_td_uid_3_59655a0133d34.header_color = "";
block_td_uid_3_59655a0133d34.ajax_pagination_infinite_stop = "";
block_td_uid_3_59655a0133d34.max_num_pages = "96";
tdBlocksArray.push(block_td_uid_3_59655a0133d34);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_3_59655a0133d34" id="td_uid_4_59655a0135a56" data-td_block_id="td_uid_3_59655a0133d34" data-td_filter_value="" href="http://theinvestigatornews.com/news/politics/">All</a><a class="mega-menu-sub-cat-td_uid_3_59655a0133d34"  id="td_uid_5_59655a0135b5a" data-td_block_id="td_uid_3_59655a0133d34" data-td_filter_value="30" href="http://theinvestigatornews.com/news/politics/cartoon/">Cartoon</a></div></div><div id=td_uid_3_59655a0133d34 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Nakivuboroad-218x150.jpg" alt="" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!">Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/prolonged-stay-power-museveni-can-plucked-via-style-pounded-self-power/" rel="bookmark" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Sevon-218x150.jpg" alt="" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/prolonged-stay-power-museveni-can-plucked-via-style-pounded-self-power/" rel="bookmark" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!">Prolonged Stay in Power? Museveni can only be Plucked Out via&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/kyotera-decides-former-rakai-district-speaker-charles-ziriddamu-steer-new-district-ahead-general-elections/" rel="bookmark" title="Kyotera Decides: Former Rakai District Speaker Charles Ziriddamu to steer new District ahead of General Elections"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kyoteradis-218x150.jpg" alt="" title="Kyotera Decides: Former Rakai District Speaker Charles Ziriddamu to steer new District ahead of General Elections"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/kyotera-decides-former-rakai-district-speaker-charles-ziriddamu-steer-new-district-ahead-general-elections/" rel="bookmark" title="Kyotera Decides: Former Rakai District Speaker Charles Ziriddamu to steer new District ahead of General Elections">Kyotera Decides: Former Rakai District Speaker Charles Ziriddamu to steer new&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/age-limit-puzzle-ugandans-directly-involved-decision-referendum/" rel="bookmark" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Sevo-2-218x150.jpg" alt="" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum"/></a></div>                <a href="http://theinvestigatornews.com/news/opinion/" class="td-post-category">Opinion</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/age-limit-puzzle-ugandans-directly-involved-decision-referendum/" rel="bookmark" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum">Age Limit Puzzle: Why Ugandans should directly be involved in this&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_59655a0133d34" data-td_block_id="td_uid_3_59655a0133d34"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_59655a0133d34" data-td_block_id="td_uid_3_59655a0133d34"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-37073"><a href="http://theinvestigatornews.com/news/crime-news/">Crime</a>
<ul  class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_59655a01381e5_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_6_59655a01381e5" ><script>var block_td_uid_6_59655a01381e5 = new tdBlock();
block_td_uid_6_59655a01381e5.id = "td_uid_6_59655a01381e5";
block_td_uid_6_59655a01381e5.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"73","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_6_59655a01381e5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_6_59655a01381e5.td_column_number = "3";
block_td_uid_6_59655a01381e5.block_type = "td_block_mega_menu";
block_td_uid_6_59655a01381e5.post_count = "5";
block_td_uid_6_59655a01381e5.found_posts = "368";
block_td_uid_6_59655a01381e5.header_color = "";
block_td_uid_6_59655a01381e5.ajax_pagination_infinite_stop = "";
block_td_uid_6_59655a01381e5.max_num_pages = "74";
tdBlocksArray.push(block_td_uid_6_59655a01381e5);
</script><div id=td_uid_6_59655a01381e5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Ruparelia-218x150.jpg" alt="" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?">Opinion: Why I Find Government not Solely Guilty of the Pearl&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/thugs-records-p-national-water-bosses-awarded-selves-houses-resold-triple-prices/" rel="bookmark" title="THUGS Records P.I: How National Water Bosses awarded selves Houses and resold them at Triple Prices"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Mugisha-218x150.jpg" alt="" title="THUGS Records P.I: How National Water Bosses awarded selves Houses and resold them at Triple Prices"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/thugs-records-p-national-water-bosses-awarded-selves-houses-resold-triple-prices/" rel="bookmark" title="THUGS Records P.I: How National Water Bosses awarded selves Houses and resold them at Triple Prices">THUGS Records P.I: How National Water Bosses awarded selves Houses and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/cip-records-nickson-warns-kayihura-will-spill-beans-not-protected-minaana-jailed-mayor-torture/" rel="bookmark" title="CIP Records: Nixon warns Kayihura he will Spill the Beans if not Protected as Minaana is jailed over Mayor Torture"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/KK2-1-218x150.jpg" alt="" title="CIP Records: Nixon warns Kayihura he will Spill the Beans if not Protected as Minaana is jailed over Mayor Torture"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/cip-records-nickson-warns-kayihura-will-spill-beans-not-protected-minaana-jailed-mayor-torture/" rel="bookmark" title="CIP Records: Nixon warns Kayihura he will Spill the Beans if not Protected as Minaana is jailed over Mayor Torture">CIP Records: Nixon warns Kayihura he will Spill the Beans if&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/cip-records-operative-flees-hiding-accusing-nixon-gen-kayihura-life-threats-museveni/" rel="bookmark" title="CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura of Life Threats before Museveni"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Kabanda-218x150.jpg" alt="" title="CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura of Life Threats before Museveni"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/cip-records-operative-flees-hiding-accusing-nixon-gen-kayihura-life-threats-museveni/" rel="bookmark" title="CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura of Life Threats before Museveni">CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/06/three-students-shot-police-botched-school-riot-scores-others-admitted-severe-injuries/" rel="bookmark" title="Three Students Shot by Police in a botched School riot, Scores of others admitted with Severe Injuries"><img width="218" height="116" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Rakai.gif" alt="Buhaari Ssewaje one of the affected students being carried to Lyantonde Ambulance to be taken to Mulago in Kampala" title="Three Students Shot by Police in a botched School riot, Scores of others admitted with Severe Injuries"/></a></div>                <a href="http://theinvestigatornews.com/news/crime-4/" class="td-post-category">Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/06/three-students-shot-police-botched-school-riot-scores-others-admitted-severe-injuries/" rel="bookmark" title="Three Students Shot by Police in a botched School riot, Scores of others admitted with Severe Injuries">Three Students Shot by Police in a botched School riot, Scores&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_59655a01381e5" data-td_block_id="td_uid_6_59655a01381e5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_6_59655a01381e5" data-td_block_id="td_uid_6_59655a01381e5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-37071"><a href="http://theinvestigatornews.com/news/opinion/">Opinions</a>
<ul  class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_7_59655a013d952_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_7_59655a013d952" ><script>var block_td_uid_7_59655a013d952 = new tdBlock();
block_td_uid_7_59655a013d952.id = "td_uid_7_59655a013d952";
block_td_uid_7_59655a013d952.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"32","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_7_59655a013d952_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_7_59655a013d952.td_column_number = "3";
block_td_uid_7_59655a013d952.block_type = "td_block_mega_menu";
block_td_uid_7_59655a013d952.post_count = "5";
block_td_uid_7_59655a013d952.found_posts = "288";
block_td_uid_7_59655a013d952.header_color = "";
block_td_uid_7_59655a013d952.ajax_pagination_infinite_stop = "";
block_td_uid_7_59655a013d952.max_num_pages = "58";
tdBlocksArray.push(block_td_uid_7_59655a013d952);
</script><div id=td_uid_7_59655a013d952 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Ruparelia-218x150.jpg" alt="" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?">Opinion: Why I Find Government not Solely Guilty of the Pearl&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/dressing-code-wastage-precious-time-discussing-misplaced-parental-obligation/" rel="bookmark" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/dressing-218x150.jpg" alt="" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!"/></a></div>                <a href="http://theinvestigatornews.com/news/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/dressing-code-wastage-precious-time-discussing-misplaced-parental-obligation/" rel="bookmark" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!">Dressing Code? What a Wastage of Precious Time discussing such a&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Nakivuboroad-218x150.jpg" alt="" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!">Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/prolonged-stay-power-museveni-can-plucked-via-style-pounded-self-power/" rel="bookmark" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Sevon-218x150.jpg" alt="" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!"/></a></div>                <a href="http://theinvestigatornews.com/news/local/" class="td-post-category">Local</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/prolonged-stay-power-museveni-can-plucked-via-style-pounded-self-power/" rel="bookmark" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!">Prolonged Stay in Power? Museveni can only be Plucked Out via&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/age-limit-puzzle-ugandans-directly-involved-decision-referendum/" rel="bookmark" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum"><img width="218" height="150" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Sevo-2-218x150.jpg" alt="" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum"/></a></div>                <a href="http://theinvestigatornews.com/news/opinion/" class="td-post-category">Opinion</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/age-limit-puzzle-ugandans-directly-involved-decision-referendum/" rel="bookmark" title="Age Limit Puzzle: Why Ugandans should directly be involved in this Decision through a Referendum">Age Limit Puzzle: Why Ugandans should directly be involved in this&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_59655a013d952" data-td_block_id="td_uid_7_59655a013d952"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_59655a013d952" data-td_block_id="td_uid_7_59655a013d952"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-38675"><a href="http://theinvestigatornews.com/travel/">Tourism</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-39383"><a target="_blank" href="http://giasafaris.com/properties/">Properties</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://theinvestigatornews.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div>


<div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://theinvestigatornews.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Business" class="entry-crumb" itemprop="url" href="http://theinvestigatornews.com/news/business/"><span itemprop="title">Business</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Opinion: Why I Find Government not Solely Guilty of the Pearl of..."><meta itemprop="url" content = "http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/">Opinion: Why I Find Government not Solely Guilty of the Pearl of...</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-40830" class="post-40830 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-crime-4 category-crime-124 category-crime-news category-featured category-opinion" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/">Joel Kenneth Ndawula</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-10T14:57:14+00:00" >July 10, 2017</time></span>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-40830">524</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top td-with-like">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F&url=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F&via=uginvestigator"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/&amp;media=http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg&description=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F%20-%20http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" data-text="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><a href="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" data-caption="Dr. Sudhir Ruparelia (R) talking to President Museveni during their hey days"><img width="620" height="330" class="entry-thumb td-modal-image" src="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" alt="" title="Ruparelia"/></a><figcaption class="wp-caption-text">Dr. Sudhir Ruparelia (R) talking to President Museveni during their hey days</figcaption></figure></div>
        <!-- WhatsApp Share Button for WordPress: http://peadig.com/wordpress-plugins/whatsapp-share-button/ --><div class="wabtn_container"><a href="whatsapp://send?text=Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? - http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" class="wabtn">Share this on WhatsApp</a></div><p>Of recent, institutions have been put under the spotlight on various accounts. Last year, we witnessed the downfall of one of Uganda’s most proclaimed commercial banks. The scandal that saw Dr. Sudhir dropping from the billionaires’ list surfaced and exposed many things that Ugandans should be worried about.</p>
<p>Crane bank, as exposed in the news today, toyed with the economy at the hands of its Vice chairman, Dr. Sudhir Ruparelia. The hardened tycoon allegedly siphoned close to Shs400b through the books accounts in his bank. Supposedly, he managed the supply of money in the economy in violation of various banking regulations. He made the banking system very fragile and with his collapse went the stability of our economy.</p>
<p>Having institutions such as these that look down on coordination are some of the reasons why the African Pearl is under developed. Having one person dictate the supply of billions of shillings in the economy breaks the constancy of the country in various sectors. It is a classic example of the income gap. The rich in the country have so much money they literally control our finances!</p>
<p>I do respect the fact that Sudhir Ruparelia made his money through hard work. However, that doesn’t give him the right to manipulate the clients’ deposits. That was simply being arrogant! The Central Bank, in their statement to sue Sudhir for fraud, has unveiled the millions of dollars that his bank was laundering through other institutions.</p>
<p>The other financial scandals are those implicating the government in cases of corruption, by the government: I mean the parliament! Some senior government officials were accused of receiving bribes to cushion the race for Tibet Hima Company for the contract to restore Kilembe Mines. The scandal involved Shs25b shared among eleven government officials.</p>
<p>Recently, parliament has made a joint venture deal with Roko Constructions Uganda and Roko Constructions Rwanda for the renovation of the current parliament chambers, construction of a new chamber and a hall of honour. The Construction Company received approximately Shs180b in the deal.</p>
<p>The deal that was finalized within a record-breaking-time of 72 hours has been faced with controversies. Roko Constructions is said to have submitted its bid on June 26, 2017 at 16:00 hours, the very date and time of submission deadline. 24 hours later, Roko Constructions’ bid was approved. On June 28th, the Clerk to Parliament sought clearance from the Solicitor General who without delay awarded the green light. Three days after the submission of its bid, out of five firms, Roko Constructions got the deal.</p>
<p>The deal was finalized in breach of PPDA’s regulations. The Public Procurement and Disposal of Public Assets requires a post-evaluation assessment on the successful bidder. However, this was ignored by the Parliament’s Contracts and Evaluation Committee. It won’t be very shocking if the project is halted over corruption and fraud cases as it happened with the Kilembe mines deal.</p>
<p>The most popular of these recent scandals besides Sudhir’s reported crime of the century, is the Centenary park controversy. Nalongo Estates, the landlord in the equation, blames KCCA for adamantly denying the enterprise a renewal of its lease on the land. When Sarah Kizito was asked to avail details of how she acquired the first lease, she couldn’t.</p>
<p>COSESA, NWSC, UNRA and KCCA are pursuing demolitions to make way for developments. NWSC requires the space to lay a sewerage drainage system. UNRA needs to continue with the planned flyover. Both bodies require the space in Centenary Park to continue the development of the capital City. However, Nalongo Estates has become a big obstacle towards the development of Uganda. Apparently, their private gain is to be prioritized over National interest!</p>
<p>The President, Chief Executive Officer of Uganda (as New Vison put it), chaired a meeting with the parties involved. He mentioned that Nalongo Estates shouldn’t be completely eliminated from the picture. It was agreed upon that it would be efficient to leave the demolitions to Nalongo Estates. Also, Nalongo estates ought to seek some sort of understanding with KCCA. The meeting resolved that Nalongo Estates should continue to use the land on condition that no permanent structures are constructed.</p>
<p>Nevertheless, it is ridiculous to have private institutions stand in the way of development for their private benefits. It is the government’s job to see that this country is moving forward in all aspects. After all, we often blame it if something doesn’t work the way we want it to. Therefore, it is atrocious to see that the likes of Crane Bank, Nalongo Estates, Tibet Hima Company, Roko Construction and the individuals involved in such scams are the reason why we can’t achieve growth.</p>
<p>It’s even sadder to know that those very parties and the nation shall continue blaming the government for our slow progress. After the government carried out massive privatization, development is left in the hands of individuals.</p>
<!-- WhatsApp Share Button for WordPress: http://peadig.com/wordpress-plugins/whatsapp-share-button/ --><div class="wabtn_container"><a href="whatsapp://send?text=Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy? - http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" class="wabtn">Share this on WhatsApp</a></div><div class="td-a-rec td-a-rec-id-content_bottom  ">===============================================================
"The Investigator is Uganda’s First Online News Daily with the Latest in Investigative Crime, Politics, Business, Entertainment, Sports, Jobs, Opinions and Analysis.  Call Us on +256 701 120000, +256 772 097871 or WhatsApp on +256 701 760099, Email: info@theinvestigatornews.com</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F&url=http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F&via=uginvestigator"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/&amp;media=http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg&description=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Opinion%3A+Why+I+Find+Government+not+Solely+Guilty+of+the+Pearl+of+Africa%E2%80%99s+steadily+ailing+Economy%3F%20-%20http%3A%2F%2Ftheinvestigatornews.com%2F2017%2F07%2Fopinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" data-text="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>                        <div class="author-box-wrap"><a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/"><img alt='mm' src='http://theinvestigatornews.com/wp-content/uploads/Untitled-1-150x148.jpg' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/">Joel Kenneth Ndawula</a></span></div><div class="td-author-url"><a href="http://www.theinvestigatornews.com">http://www.theinvestigatornews.com</a></div><div class="td-author-description">Kenneth is currently a Mass Communication student at St Lawrence University. He holds a certificate in History and Literature. He is a social political critique, good creative writer and a poet.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://kenndawulaimages.blogspot.ug" title="Blogger">
                <i class="td-icon-font td-icon-blogger"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/insiderpost/?ref=bookmarks" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Joel Kenneth Ndawula"></span><meta itemprop="datePublished" content="2017-07-10T14:57:14+00:00"><meta itemprop="dateModified" content="2017-07-10T14:57:14+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://theinvestigatornews.com/wp-content/uploads/2016/07/Logo.jpg"></span><meta itemprop="name" content="The Investigator"></span><meta itemprop="headline " content="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg"><meta itemprop="width" content="620"><meta itemprop="height" content="330"></span>        </footer>

    </article> <!-- /.post -->

    

<div id="disqus_thread">
    </div>

                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_18 td_block_widget td_uid_9_59655a03eee92_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_9_59655a03eee92" ><script>var block_td_uid_9_59655a03eee92 = new tdBlock();
block_td_uid_9_59655a03eee92.id = "td_uid_9_59655a03eee92";
block_td_uid_9_59655a03eee92.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"LATEST NEWS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"load_more","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_9_59655a03eee92_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_9_59655a03eee92.td_column_number = "1";
block_td_uid_9_59655a03eee92.block_type = "td_block_18";
block_td_uid_9_59655a03eee92.post_count = "5";
block_td_uid_9_59655a03eee92.found_posts = "9277";
block_td_uid_9_59655a03eee92.header_color = "#";
block_td_uid_9_59655a03eee92.ajax_pagination_infinite_stop = "";
block_td_uid_9_59655a03eee92.max_num_pages = "1856";
tdBlocksArray.push(block_td_uid_9_59655a03eee92);
</script><h4 class="block-title"><span>LATEST NEWS</span></h4><div id=td_uid_9_59655a03eee92 class="td_block_inner td-column-1">
        <div class="td_module_mx8 td_module_wrap td-animation-stack">
            <div class="meta-info-container">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"><img width="620" height="330" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Ruparelia.jpg" alt="" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?"/></a></div>
                <div class="td-module-meta-info">
                    <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy/" rel="bookmark" title="Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?">Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa’s steadily ailing Economy?</a></h3>                                        <span class="td-author-date">
                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/">Joel Kenneth Ndawula</a> <span>-</span> </span>                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-10T14:57:14+00:00" >July 10, 2017</time></span>                                            </span>
                </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/dressing-code-wastage-precious-time-discussing-misplaced-parental-obligation/" rel="bookmark" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!"><img width="80" height="60" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/dressing-80x60.jpg" alt="" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/dressing-code-wastage-precious-time-discussing-misplaced-parental-obligation/" rel="bookmark" title="Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!">Dressing Code? What a Wastage of Precious Time discussing such a Misplaced Parental Obligation!</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T13:56:08+00:00" >July 7, 2017</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"><img width="80" height="60" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/Nakivuboroad-80x60.jpg" alt="" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!">Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T13:19:41+00:00" >July 7, 2017</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/rookie-singer-joz-b-storms-industry-multi-million-video-project-sofie-hit-song-will-humble-sheeba-karungi/" rel="bookmark" title="Rookie Singer Joz B Storms Industry with Multi Million Video Project for his ‘Sofie’ Hit Song that will Humble Sheeba Karungi"><img width="80" height="43" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/JosB.gif" alt="singer Julius Tumwesigye aka Joz B" title="Rookie Singer Joz B Storms Industry with Multi Million Video Project for his ‘Sofie’ Hit Song that will Humble Sheeba Karungi"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/rookie-singer-joz-b-storms-industry-multi-million-video-project-sofie-hit-song-will-humble-sheeba-karungi/" rel="bookmark" title="Rookie Singer Joz B Storms Industry with Multi Million Video Project for his ‘Sofie’ Hit Song that will Humble Sheeba Karungi">Rookie Singer Joz B Storms Industry with Multi Million Video Project for his ‘Sofie’ Hit Song that will Humble Sheeba Karungi</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T13:02:38+00:00" >July 7, 2017</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/07/revival-church-bombo-pastor-siraje-ssemanda-returns-israel-confirming-200-believers-pilgrimage-holy-land/" rel="bookmark" title="Revival Church Bombo Pastor Siraje Ssemanda Returns From Israel after Confirming 200 Believers Pilgrimage to the Holy Land"><img width="80" height="43" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/pastor.gif" alt="Pastor Sirajje in white at Entebbe" title="Revival Church Bombo Pastor Siraje Ssemanda Returns From Israel after Confirming 200 Believers Pilgrimage to the Holy Land"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/revival-church-bombo-pastor-siraje-ssemanda-returns-israel-confirming-200-believers-pilgrimage-holy-land/" rel="bookmark" title="Revival Church Bombo Pastor Siraje Ssemanda Returns From Israel after Confirming 200 Believers Pilgrimage to the Holy Land">Revival Church Bombo Pastor Siraje Ssemanda Returns From Israel after Confirming 200 Believers Pilgrimage to the Holy Land</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T12:55:35+00:00" >July 7, 2017</time></span>                                    </div>
            </div>

        </div>

        </div><div class="td-load-more-wrap"><a href="#" class="td_ajax_load_more td_ajax_load_more_js" id="next-page-td_uid_9_59655a03eee92" data-td_block_id="td_uid_9_59655a03eee92">Load more<i class="td-icon-font td-icon-menu-down"></i></a></div></div> <!-- ./block --><div class="td_block_wrap td_block_9 td_block_widget td_uid_10_59655a0403e1e_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_10_59655a0403e1e" ><script>var block_td_uid_10_59655a0403e1e = new tdBlock();
block_td_uid_10_59655a0403e1e.id = "td_uid_10_59655a0403e1e";
block_td_uid_10_59655a0403e1e.atts = '{"limit":"5","sort":"popular7","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"MUST READ","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"load_more","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_10_59655a0403e1e_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_10_59655a0403e1e.td_column_number = "1";
block_td_uid_10_59655a0403e1e.block_type = "td_block_9";
block_td_uid_10_59655a0403e1e.post_count = "5";
block_td_uid_10_59655a0403e1e.found_posts = "8820";
block_td_uid_10_59655a0403e1e.header_color = "#";
block_td_uid_10_59655a0403e1e.ajax_pagination_infinite_stop = "";
block_td_uid_10_59655a0403e1e.max_num_pages = "1764";
tdBlocksArray.push(block_td_uid_10_59655a0403e1e);
</script><h4 class="block-title"><span>MUST READ</span></h4><div id=td_uid_10_59655a0403e1e class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/thugs-records-p-national-water-bosses-awarded-selves-houses-resold-triple-prices/" rel="bookmark" title="THUGS Records P.I: How National Water Bosses awarded selves Houses and resold them at Triple Prices">THUGS Records P.I: How National Water Bosses awarded selves Houses and resold them at...</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/admin/">Stanley Ndawula</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-06T14:16:51+00:00" >July 6, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/cip-records-nickson-warns-kayihura-will-spill-beans-not-protected-minaana-jailed-mayor-torture/" rel="bookmark" title="CIP Records: Nixon warns Kayihura he will Spill the Beans if not Protected as Minaana is jailed over Mayor Torture">CIP Records: Nixon warns Kayihura he will Spill the Beans if not Protected as...</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/admin/">Stanley Ndawula</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-05T19:42:32+00:00" >July 5, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/prolonged-stay-power-museveni-can-plucked-via-style-pounded-self-power/" rel="bookmark" title="Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style he pounded self in Power!">Prolonged Stay in Power? Museveni can only be Plucked Out via the Same Style...</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/">Joel Kenneth Ndawula</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-05T17:17:25+00:00" >July 5, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/stagnant-progress-renaming-nakivubo-road-ssebaana-kizito-abuse-independence/" rel="bookmark" title="Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our Independence!">Stagnant Progress: Why Renaming Nakivubo Road after Ssebaana Kizito is an abuse to our...</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/joel-kenneth-ndawula/">Joel Kenneth Ndawula</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T13:19:41+00:00" >July 7, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/07/cip-records-operative-flees-hiding-accusing-nixon-gen-kayihura-life-threats-museveni/" rel="bookmark" title="CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura of Life Threats before Museveni">CIP Records: Operative Flees into Hiding after Accusing Nixon, Gen. Kayihura of Life Threats...</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/rosand/">Robert Ndawula</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-03T15:16:17+00:00" >July 3, 2017</time></span>                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-load-more-wrap"><a href="#" class="td_ajax_load_more td_ajax_load_more_js" id="next-page-td_uid_10_59655a0403e1e" data-td_block_id="td_uid_10_59655a0403e1e">Load more<i class="td-icon-font td-icon-menu-down"></i></a></div></div> <!-- ./block -->                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->


<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-40107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-40107"><a href="http://theinvestigatornews.com/privacy-policy/">Privacy</a></li>
<li id="menu-item-40108" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40108"><a href="http://theinvestigatornews.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-36784" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36784"><a href="#">Advertisement</a></li>
<li id="menu-item-36785" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-36785"><a href="http://theinvestigatornews.com/contact/">Contact Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; The Investigator is Owned and Powered by GIA Investments                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

		<script type="text/javascript">
			jQuery(document).ready(function () {
				jQuery("#post-right-col,#post-sidebar-wrap,.home-mid-col,.home-right-col,#arch-right-col").theiaStickySidebar({"containerSelector":"","additionalMarginTop":65,"additionalMarginBottom":15,"updateSidebarHeight":false,"minWidth":767,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true});
			});
		</script>
		                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://theinvestigatornews.com/2017/01/end-road-top-coftu-leaders-resign-join-rival-camp-notu-trade-union-leader-lyomoki-recalled-parliament/" rel="bookmark" title="END OF THE ROAD: Top COFTU leaders Resign to Join Rival Camp NOTU As Trade Union leader Lyomoki to be Recalled from Parliament"><img width="324" height="160" class="entry-thumb" src="http://theinvestigatornews.com/wp-content/uploads/OWERE-324x160.jpg" alt="Usher Wilson Owere, the Chairman General NOTU" title="END OF THE ROAD: Top COFTU leaders Resign to Join Rival Camp NOTU As Trade Union leader Lyomoki to be Recalled from Parliament"/></a></div>                <a href="http://theinvestigatornews.com/news/business/" class="td-post-category">Business</a>            </div>
            <h3 class="entry-title td-module-title"><a href="http://theinvestigatornews.com/2017/01/end-road-top-coftu-leaders-resign-join-rival-camp-notu-trade-union-leader-lyomoki-recalled-parliament/" rel="bookmark" title="END OF THE ROAD: Top COFTU leaders Resign to Join Rival Camp NOTU As Trade Union leader Lyomoki to be Recalled from Parliament">END OF THE ROAD: Top COFTU leaders Resign to Join Rival...</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="http://theinvestigatornews.com/author/patrick-jaramoji/">Patrick Jaramogi</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-01-30T14:05:19+00:00" >January 30, 2017</time></span>                            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 59655a06923ee
    -->

    <script>
    jQuery(document).ready(function () {
		jQuery.post('http://theinvestigatornews.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/theinvestigatornews.com\/wp-json\/","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.8'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.5.0'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8","language":""},"disqusIdentifier":"40830 http:\/\/theinvestigatornews.com\/?p=40830","disqusShortname":"investigatorug","disqusTitle":"Opinion: Why I Find Government not Solely Guilty of the Pearl of Africa\u2019s steadily ailing Economy?","disqusUrl":"http:\/\/theinvestigatornews.com\/2017\/07\/opinion-find-government-not-solely-guilty-pearl-africas-steadily-ailing-economy\/","options":{"manualSync":false},"postId":"40830"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"investigatorug"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theinvestigatornews.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[40830]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://theinvestigatornews.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://theinvestigatornews.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>